Apr 21st Critical WordPress Security Update

WordPress 4.1.2 is now available. This is acritical security releasefor all previous versions and we strongly encourage you to update your sites immediately. WordPress versions 4.1.1 and earlier are affected by a critical cross-site scripting vulnerability, which could enable anonymous users to compromise a site. Security Updates Issued An ... Read More »